Linux Blog

I got a Mac

Filed under: Linux Hardware,The Linux Blog News — TheLinuxBlog.com at 2:05 am on Tuesday, July 9, 2013

I’m not really a huge consumer of hardware, but I today I got a Mac, more specifically a MacBook Air. It is my first brand new computer since I built my desktop which I probably never wrote about. I didn’t pay for it, as it was promotional item from training I signed up for. I had a choice of a Toshiba Ultrabook that never really closes, or the MacBook Air. After I thought about it, the choice was not too hard, I choose the one that would have the higher re-sale value, the better of the two OS’s, and probably better Linux support.

So far I’m impressed, it is a very elegant design, the internal hardware is meh but it does have a SSD which is the first I’ve owned. It would be nice to try and hook up an external monitor, but I’m not sinking any money into it, because I don’t really want to pay the standard $79 apple accessory fee, and am not sure if the thunderbolt port even converts to HDMI, and I’m sure as hell not going to buy a thunderbolt display. There is only two USB ports, which is rather pathetic, even my Netbook manages to squeeze 3, a VGA port and a media card reader in. As far as OSX, I’m not so happy with, it has a few nuances that will take some getting used to, such as the command key which changes the way I use the keyboard (command+t, command+w, etc.) There is probably a fix for that and I’ve already changed some settings to make it more familiar.

My DNS-323 NAS had to have some changes to the Samba config using funplug as it doesn’t connect with SECURITY=SHARE, it has to be SECURITY=USER, not sure why that is. I’m happy to report that my SDR experiments were just as hard with OSX as they were with Linux, I blame that to not really knowing much about radio theory. Other than that, installing XCode, Macports and writing this post I haven’t really had much time to play with it. I’ll stick out using OSX until the training is over, then I’ll look at another OS. Until then, it’ll be VM’s and SSH connections into the desktop PC, which while aging still has more horse power than the Air.

image source: http://www.flickr.com/photos/dansapples/7157645924/

VMWare: “Unable to build the vmnet module”

Filed under: General Linux,Linux Software — TheLinuxBlog.com at 10:49 am on Monday, July 21, 2008

If you run into the following problem:

VMware Server is installed, but it has not been (correctly) configured
for the running kernel. To (re-)configure it, invoke the
following command: /usr/local/bin/vmware-config.pl.

and then try to issue the vmware-config.pl command and get something similar to the following:

/tmp/vmware-config1/vmnet-only/bridge.c: In function ‘VNetBridgeUp’:
/tmp/vmware-config1/vmnet-only/bridge.c:949: error: implicit declaration of function ‘sock_valbool_flag’
make[2]: *** [/tmp/vmware-config1/vmnet-only/bridge.o] Error 1
make[1]: *** [_module_/tmp/vmware-config1/vmnet-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.25.10-47.fc8-i686'
make: *** [vmnet.ko] Error 2
make: Leaving directory `/tmp/vmware-config1/vmnet-only'
Unable to build the vmnet module.

Then try to use the VMWare any patch from: http://groups.google.com/group/vmkernelnewbies/files
I had used the patch before to get my VMWare Server up and running but did not realize that you had to use the patch after kernel upgrade or your VMWare server will no longer work.

Who knew?